#!/bin/bash

# Slackware build script for tclblt

# Copyright 2019 Andrey Lipaev Moscow
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# 20220222 bkw: Modified by SlackBuilds.org, BUILD=2:
# - add -j1 to make commands (parallel builds fail).
# - do not install libraries to /usr/lib on x86_64.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=tclblt
VERSION=${VERSION:-2.5.3}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
SRC="blt-src-2.5.3.zip"
SRC_HOME="blt2.5"

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRC_HOME
unzip $CWD/$SRC
cd $SRC_HOME
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \+ -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+

#Here we will apply the patches from Debian project
rm -rv library/dd_protocols && patch -p1 < $CWD/patches/source.patch && sed -i -e 's/\$$(ddFiles)//' library/Makefile.in
PATCHLIST=" 02-debian-all.patch \
	03-fedora-patch-2.patch \
	04-fedora-tk8.5.6.patch \
	05-tk8.5-zoomstack.patch \
	doc-typos.patch \
	tcl8.6.patch \
	tk8.6.patch \
	install.patch \
	usetclint.patch \
	table.patch \
	ldflags.patch \
	pkgindex.patch \
	decls.patch \
	bltnsutil.patch \
	blthash.patch \
	const.patch \
	uninitialized.patch \
	unused.patch \
	pointertoint.patch \
	autoreconf.patch \
	switch.patch"
#	usetkint.patch \

for PATCH in $PATCHLIST ; do echo $CWD/patches/$PATCH ; patch -p1 <  $CWD/patches/$PATCH ; done

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --build=$ARCH-slackware-linux \
  --with-tcl=/usr/lib${LIBDIRSUFFIX} \
  --with-blt=/usr/lib${LIBDIRSUFFIX} \
  --with-tcllibs=/usr/lib${LIBDIRSUFFIX}

make -j1
make -j1 install INSTALL_ROOT=$PKG
gzip -9 $PKG/usr/man/man*/*

# 20220225 bkw: configure doesn't respect --disable-static, for now
# just leave the static libs.

# 20220225 bkw: documentation getting installed in /usr/lib
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
mv $PKG/usr/lib/blt*/{NEWS,PROBLEMS,README,demos} $PKGDOC

# 20220225 bkw: --libdir not fully respected
if [ -n "$LIBDIRSUFFIX" ]; then
  mv $PKG/usr/lib/*.{so,a} $PKG/usr/lib$LIBDIRSUFFIX
  rm -rf $PKG/usr/lib
fi

strip $PKG/usr/bin/* $PKG/usr/lib$LIBDIRSUFFIX/*.so

cp -a html $PKGDOC
cp -a examples $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
find $PKGDOC -type f -exec chmod 644 {} \+

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE