#!/bin/bash
#
# Slackware build script for sbotools
#
# Written by Jacob Pipkin <j@dawnrazor.net>
# Copyright 2024-2025 K. Eugene Carlson <kvngncrlsn@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=sbotools
VERSION=${VERSION:-3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

ARCH=noarch

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

( cd SBO-Lib
	/usr/bin/perl Makefile.PL \
	  PREFIX=/usr \
	  INSTALLDIRS=site \
	  INSTALLVENDORMAN1DIR=/usr/man/man1 \
	  INSTALLVENDORMAN3DIR=/usr/man/man3 \
	  INSTALLMAN3DIR=none
	make
	make test
	make install DESTDIR=$PKG
)

SCRIPTS="check clean config find hints install remove upgrade"
ANYONE="check config find hints install upgrade"
MANS="man1 man3 man5"

mkdir -p $PKG/usr/sbin \
         $PKG/usr/share/zsh/site-functions \
         $PKG/usr/share/bash-completion/completions
for i in $SCRIPTS; do
  install -m 0755 sbo$i $PKG/usr/sbin
  install -m 0644 completions/zsh/_sbo$i $PKG/usr/share/zsh/site-functions
  install -m 0644 completions/bash/sbo$i $PKG/usr/share/bash-completion/completions/sbo$i
done
# sbofind and parts of some other scripts can be used without root
mkdir -p $PKG/usr/bin
(
cd $PKG/usr/bin
for i in $ANYONE; do
  ln -s ../sbin/sbo$i $PKG/usr/bin
done
)

# sbosnap compatibility completions
install -m 0644 completions/zsh/_sbosnap $PKG/usr/share/zsh/site-functions
install -m 0644 completions/bash/sbosnap $PKG/usr/share/bash-completion/completions/sbosnap

for i in $MANS; do
  mkdir -p $PKG/usr/man/$i
  install -m 0644 $i/* $PKG/usr/man/$i
done

# Make the sbosnap compatibility symlinks
(
cd $PKG/usr/sbin
ln -s sbocheck sbosnap
cd $PKG/usr/man/man1
ln -s sbocheck.1 sbosnap.1
)

mkdir -p $PKG/etc/sbotools
cp etc/obsolete $PKG/etc/sbotools/obsolete
cp etc/sbotools.conf $PKG/etc/sbotools/sbotools.conf.new
cp etc/sbotools.hints $PKG/etc/sbotools/sbotools.hints.new

find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz; rm $i ; done

find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true

find $PKG -depth -type d -empty -delete || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/SBO-Lib
cp -a SBO-Lib/README SBO-Lib/Changes $PKG/usr/doc/$PRGNAM-$VERSION/SBO-Lib
cp -a LICENSE THANKS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE